System requirements for Fire Sprinklers

Software versions

  • Released versions: Fire Sprinklers 2021.7, 2020.6, 2019.4, 2018.4, 2017.2 (previous 2017.1), 2016.3, 2015.3, 2014.1, 2013.1, 2012.2
  • Unit systems: Metric and Imperial
  • Language: English


System Requirements

  • Same as for Autodesk® Revit®
  • Operating systems: 64-bit versions of Windows 10, Windows 8.1, Windows 7

    Compatible with Autodesk® Revit® 2021, 2020, 2019

Software versions supported for only the two most-recent versions of Revit®.

Related products

Cut Opening
MEP Hangers

Recommended products

Quick Dimensions
RAS Manager
Smart Browser